Issue at Exact
Minor incident
Accounting systems
Exact Online
02-09-2026 10:12 CEST
· 3 hours, 55 minutes
Updates
Resolved
02-09-2026 · 14:07 CEST
The outage has been resolved by Exact. All Exact Online administrations are accessible again.
Monitoring
02-09-2026 · 14:02 CEST
Exact has rolled out a fix, making most Exact Online environments accessible again. However, some users with Exact Online Premium may still experience problems.
Issue
02-09-2026 · 10:12 CEST
There is currently an issue at Exact Online which may cause you to experience problems while working with TriFact365.
Exact is working on a solution. Keep an eye on the Exact status page for updates.
← Back
Status