Issue in the mobile app

Major incident TriFact365 Mobile app
01-07-2026 07:00 CEST · 1 hour, 58 minutes

Updates

Resolved

The issue has been resolved. The mobile app is working properly again.

01-07-2026 · 08:58 CEST
Issue

Due to a malfunction in the mobile app, no data can be retrieved. The message ‘No administrations linked’ appears in the app. We are working on a solution.

01-07-2026 · 07:00 CEST

← Back