Outage in recognition of documents

Major incident TriFact365 AI document recognition
26-06-2026 12:38 CEST · 22 minutes

Updates

Resolved

The outage has been resolved. We apologize for the inconvenience.

26-06-2026 · 12:59 CEST
Issue

There is currently an outage causing uploaded documents to remain on the ‘Recognition’ status. We are working on a solution. We advise you not to upload these documents again.

26-06-2026 · 12:38 CEST

← Back